Linux/vim2013.08.01 15:04
 


환경 : ubuntu 12.04 (64-bit)

  Vim 플러그인 중에 일부는 ruby로 작성된 것들이있다(예:Command-T). 하지만 거의 대부분의 패키지로 설치된 vim은 기본적으로 ruby를 지원하지 않도록 되어있다. 설치된 Vim이 ruby를 지원하는지 확인 하는 방법은 다음과 같다.


 $ vim --version | grep ruby  

 

  위와 같이 입력했을 때, -ruby 라고 출력되면 ruby를 지원하지 않는 것이다. 기존에 패키지로 설치된 vim을 지우고, 새롭게 컴파일해서 설치할 수 있도록 준비한다.


 $ sudo apt-get remove vim-common vim-runtime vim-gtk vim-gui-common
 $ sudo apt-get build-dep vim    

 

  그리고 ruby를 지원할 수 있도록 새롭게 빌드한다.

 

 $ hg clone https://vim.googlecode.com/hg/ vim
 $ cd vim
 $ ./configure --enable-rubyinterp --enable-pythoninterp
 $ make
 $ sudo make install  

 

 추가적으로 configure 할 때 다음 옵션을 포함시켜도 된다. 


./configure --with-features=huge \
            --enable-rubyinterp \
            --enable-pythoninterp \
            --enable-perlinterp \
            --enable-gui=gtk2 \ 
	    --enable-cscope \
 	    --enable-luainterp    

 

'Linux > vim' 카테고리의 다른 글

Vim에서 ruby, python을 지원하도록 설치하는 방법  (0) 2013.08.01
vi 치환  (0) 2009.11.25
vi 창 설정  (0) 2009.11.25
vim 팁  (0) 2009.11.24
vim 단축키  (0) 2009.11.23
/etc/vim/vimrc  (0) 2009.11.23


Posted by bayron

티스토리 툴바